Platform Outage

Incident Report for Status • Church Online Platform

Resolved

This issue has been resolved.
Posted Feb 24, 2026 - 17:26 CST

Update

🔧 Service Update

We are currently experiencing an issue with vanity domain URLs on the Church Online Platform. If your church uses a custom URL to access your online experience (e.g., live.life.church), you may be seeing an internal server error.

Your experience is still fully available through your standard Church Online Platform URL:
👉 https://yourchurch.online.church/

We are aware of the issue and are actively working on it. We will provide an update as soon as we resolve it.

Thank you for your patience.
Posted Feb 24, 2026 - 14:53 CST

Investigating

We are actively investigating a known outage. We know these issues can have a significant impact on your ministry & are working diligently to fix this issue.
Posted Feb 24, 2026 - 12:54 CST
This incident affected: Church Online Platform Availabliity.