This is a Test Notification

Incident Report for Status • Church Online Platform

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 16:45 CST

Investigating

We are testing communication for the Church Online Platform. No issues are currently impacting the Church Online Platform.
Posted Feb 12, 2025 - 16:42 CST
This incident affected: Church Online Platform Availabliity.