Platform Outage

Incident Report for Status • Church Online Platform

Resolved

We are testing our alerting to ensure we are ready for Easter services. We are praying for your church and cheering you on this weekend!
Posted Apr 17, 2025 - 11:17 CDT

Investigating

We are actively investigating a known outage. We know these issues can have a significant impact on your ministry & are working diligently to fix this issue.
Posted Apr 17, 2025 - 11:14 CDT
This incident affected: Church Online Platform Availabliity.