Platform Outage

Incident Report for Status • Church Online Platform

Resolved

This incident has been resolved. We know these issues impact your ministry and appreciate your patience!
Posted Nov 24, 2024 - 08:50 CST

Monitoring

A fix has been implemented and we are monitoring for stability.
Posted Nov 24, 2024 - 08:24 CST

Investigating

We are actively investigating a known outage. We know these issues can have a significant impact on your ministry & are working diligently to fix this issue!
Posted Nov 24, 2024 - 08:20 CST