Service Outage
Incident Report for Status • Church Online Platform
Resolved
This incident has been resolved, and our team will continue to monitor.
Posted Aug 03, 2020 - 15:35 CDT
Identified
Our team has identified the issue and is working on a potential fix. We'll continue to keep you updated.
Posted Aug 03, 2020 - 15:20 CDT
Investigating
Our team is currently investigating an issue with some church services not loading. We'll provide an update shortly.
Posted Aug 03, 2020 - 14:48 CDT