Known Issue

Incident Report for Status • Church Online Platform

Resolved

This incident has been resolved.
Posted Jun 21, 2025 - 15:03 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2025 - 13:13 CDT

Investigating

We are investigating an issue with data reporting. We know situations like this can have a significant impact on your ministry & are working diligently toward a solution.
Posted Jun 21, 2025 - 07:49 CDT