Service Outage
Incident Report for Status • Church Online Platform
Resolved
This issue has been resolved. Our team will continue to monitor.
Posted Sep 15, 2020 - 12:28 CDT
Investigating
We are currently investigating a 502 error. We will keep you informed of any updates.
Posted Sep 15, 2020 - 12:22 CDT