Service Analytics
Incident Report for Status • Church Online Platform
Resolved
This incident has been resolved.
Posted Feb 15, 2021 - 19:22 CST
Investigating
Our team is currently investigating an issue with Service Analytics not displaying service data. We're working to discover the cause and implement a fix.
Posted Feb 15, 2021 - 19:01 CST