Platform Outage
Incident Report for Status • Church Online Platform
Resolved
This incident has been resolved and we'll continue to monitor.
Posted Mar 28, 2021 - 08:57 CDT
Update
Our team has implemented a fix for the slowing down of the system, resulting in services being restored. We will continue to monitor.
Posted Mar 28, 2021 - 08:15 CDT
Investigating
Our team is currently investigating an issue. We'll update you as soon as we have more information.
Posted Mar 28, 2021 - 07:59 CDT