Platform Outage

Incident Report for Status • Church Online Platform

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 16:52 CST

Update

We are continuing to investigate this issue.
Posted Feb 12, 2025 - 16:52 CST

Investigating

We are actively investigating a known outage. We know these issues can have a significant impact on your ministry & are working diligently to fix this issue.
Posted Feb 12, 2025 - 16:51 CST
This incident affected: Church Online Platform Availabliity.