Slow Loading Times

Incident Report for Status • Church Online Platform

Resolved

Errors and Latency has returned to normal. We will continue to monitor and investigate what happened for preventative measures.
Posted May 28, 2023 - 10:45 CDT

Monitoring

A fix has been implemented and we are monitoring the results. Stay posted for a full resolution.
Posted May 28, 2023 - 10:23 CDT

Investigating

We’re currently experiencing slow loading times system wide. Our engineers are actively working on a fix.
Posted May 28, 2023 - 09:37 CDT